summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShaun McCance <shaunm@gnome.org>2012-05-14 14:15:33 -0400
committerShaun McCance <shaunm@gnome.org>2012-05-14 14:15:33 -0400
commitd4f1b9512988e6588c190b3ac16c1604cab3f5ab (patch)
treed0676d23875d8ffdfed3652b0522c538b83e79fe /configure.ac
parente03d3c810798c0bb41b3142d2f3427ddd897cd37 (diff)
downloadyelp-d4f1b9512988e6588c190b3ac16c1604cab3f5ab.tar.gz
Fixed my mistake in generating yelp.pot for xslt translations
I was generating the POT file from the generated yelp.xml instead of from the source yelp.xml.in. Since the generated file doesn't have the ITS rules, <string/> was not withinText, so itstool used a placeholder, so no translations actually matched. I fixed the Makefile and all of the translations. Also, I was using ALL_LINGUAS to create the POT file, just like yelp-xsl does. But I wasn't setting ALL_LINGUAS in configure.ac. Fixed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b45a4eb..5b98949e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,9 @@ fi
# i18n stuff
IT_PROG_INTLTOOL([0.41.0])
+ALL_LINGUAS="`grep -v '^#' "$srcdir/po/LINGUAS" | tr '\n' ' '`"
+AC_SUBST(ALL_LINGUAS)
+
AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION([0.17])