summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMikael Hallendal <micke@codefactory.se>2002-10-19 16:22:37 +0000
committerMikael Hallendal <hallski@src.gnome.org>2002-10-19 16:22:37 +0000
commit232bf89fd42ffbcc88a9425727cccdc11015af22 (patch)
treedabb1884563e273840e7cf4102be39ae21564480 /configure.in
parent5036724b58539df142f2c9dc45891b8d85936cfb (diff)
downloadyelp-232bf89fd42ffbcc88a9425727cccdc11015af22.tar.gz
link with POPT_LIBS.
2002-10-19 Mikael Hallendal <micke@codefactory.se> * src/Makefile.am (yelp_LDADD): link with POPT_LIBS. * configure.in: Check for popt, fixes #96168
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 584935d4..137d83b3 100644
--- a/configure.in
+++ b/configure.in
@@ -81,6 +81,14 @@ dnl <= Check for bzip2 > 1.0.0
AC_CHECK_LIB(bz2, BZ2_bzread, [AC_DEFINE(HAVE_LIBBZ2)])
dnl =>
+dnl ===================================================
+dnl = Check for popt, reported to be needed on AIX
+dnl ===================================================
+AC_CHECK_LIB(popt, poptGetArgs, [POPT_LIBS="-lpopt"],
+ [AC_MSG_ERROR([popt is required to build yelp])])
+
+AC_SUBST(POPT_LIBS)
+
if test x$with_html_widget = xgtkhtml1; then
PKG_CHECK_MODULES(HTML_WIDGET, libgtkhtml-3.0 >= 3.0)
else