summaryrefslogtreecommitdiff
path: root/libyelp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libyelp/Makefile.am')
-rw-r--r--libyelp/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/libyelp/Makefile.am b/libyelp/Makefile.am
index ec37d29e..73efd41d 100644
--- a/libyelp/Makefile.am
+++ b/libyelp/Makefile.am
@@ -1,3 +1,8 @@
+# Libtool is utterly broken when it comes to ordering library dependencies.
+# Hack around this awfulness: https://lists.gnu.org/archive/html/libtool/2004-10/msg00051.html
+# As libyelp depends on libyelpcommon, force libyelpcommon to be installed
+# first.
+install-exec-am: install-pkglibLTLIBRARIES install-libLTLIBRARIES
pkglib_LTLIBRARIES = libyelpcommon.la
libyelpcommon_la_SOURCES = \