summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-09-13 10:37:54 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2016-09-14 06:20:47 +0200
commitee93e33700140cfc15fe0d12c455bdae611d50d3 (patch)
treecfbbb71c95b2647b3c5775cf2179f1e161fc2942 /Makefile.am
parentb27b71286224c34f3a83f194aaf663a83990c84f (diff)
downloadgnutls-ee93e33700140cfc15fe0d12c455bdae611d50d3.tar.gz
Makefile.am: introduced 'make files-update' rule
This rule updates the makefiles in doc/ and the kept symbol list. This allows for easier automation of the symbol change 'make dist' breakages.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 994d200e1a..d4c313b126 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -93,7 +93,7 @@ symbol-check:
else \
echo "*************************************************************"; \
echo "Symbols were added in the library; check symbols.diff.tmp for"; \
- echo "correctness and then copy symbols.last.tmp over symbols.last"; \
+ echo "correctness; then use 'make files-update'"; \
echo "*************************************************************"; \
false; \
fi \
@@ -110,6 +110,14 @@ symbol-check:
local-code-coverage-output: code-coverage-capture
cat GnuTLS-$(VERSION)-coverage/index.html|grep headerCovTableEntryLo|head -1|sed 's/^.*>\([0-9]\+\.[0-9]\+\s*%\)<.*$$/ coverage lines: \1/' || true
+files-update:
+ make -C doc/ compare-makefile || mv doc/tmp-compare-makefile doc/Makefile.am
+ make -C doc/manpages compare-makefile || mv doc/manpages/tmp-compare-makefile doc/manpages/Makefile.am
+ make -C . symbol-check || mv symbols.last.tmp symbols.last
+ echo "******************************************************************************************"
+ echo "updated auto-generated files; please use git diff to verify the correctness of the changes"
+ echo "******************************************************************************************"
+
dist-hook: symbol-check abi-check
make -C doc/ compare-makefile
make -C doc/ compare-exported