summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2014-03-06 19:08:46 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2014-03-06 19:08:51 +0100
commite9191689b9a2df8321c4dc8cf558e5b0c709d5dc (patch)
tree1d459448ccbb9f29661107fdc870132a278c21a1 /Makefile.am
parent707c3ddf46de387a3cf269604d6e2052713f15c6 (diff)
downloadgnutls-e9191689b9a2df8321c4dc8cf558e5b0c709d5dc.tar.gz
Added symbol check prior to release (after discussion with Andreas Metzler)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c524bc0e65..8114f5078f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,6 +47,14 @@ dist-hook:
make -C doc/ compare-makefile
make -C doc/ compare-exported
make -C doc/manpages compare-makefile
+ echo "*****************************************************************"
+ echo "Checking symbol changes. If the next step fails, verify that the"
+ echo "symbols added or removed are correct and copy symbols.last.tmp as"
+ echo "symbols.last"
+ echo "*****************************************************************"
+ objdump -T $(srcdir)/lib/.libs/libgnutls.so.28 | grep -v ' \*UND\*' | awk '{print $$7 "@" $$6;}' | sort -u >symbols.last.tmp
+ diff -u symbols.last symbols.last.tmp >/dev/null 2>&1
+ rm -f symbols.last.tmp
rm -f ChangeLog
make ChangeLog
cp -f ChangeLog $(distdir)/