summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-09-13 08:46:51 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-09-13 09:07:48 +0200
commit3db5d5ffe135c7533b5b8f1b016d9a2501ff667d (patch)
treeaa5fe59f1322d0fb0ecb6df8e41e7d86ab33817d /Makefile.am
parent5afe97a600be5fc3ba98fd161f01b41f3bfa0c84 (diff)
downloadgnutls-3db5d5ffe135c7533b5b8f1b016d9a2501ff667d.tar.gz
Makefile.am: added check for position dependent code
This check will verify that the generated library doesn't contain position dependent code. It depends on elf utilities.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c236019360..a2290b7071 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,6 +57,13 @@ EXTRA_DIST = cfg.mk maint.mk .clcopying CONTRIBUTING.md README.md LICENSE AUTHOR
TMPFILE="abi-temp.xml"
+pic-check:
+ @echo "Checking for position dependent code"
+ readelf -d $(builddir)/lib/.libs/libgnutls.so|grep TEXTREL; if test $$? = 0;then \
+ eu-findtextrel $(builddir)/lib/.libs/libgnutls.so; \
+ false; \
+ fi
+
abi-check:
@rm -f $(TMPFILE)
@echo "Checking libgnutls ABI"