summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlon Bar-Lev <alon.barlev@gmail.com>2019-04-03 18:42:26 +0300
committerAlon Bar-Lev <alon.barlev@gmail.com>2019-04-09 20:19:31 +0300
commit499a021b968033057944492ee3074f0898aa4dba (patch)
tree5cbd52096309c5c42a337caeba62ec85b72e9e48 /Makefile.am
parente360b641eedddd2dea389d9fd860a86ff21297a1 (diff)
downloadgnutls-499a021b968033057944492ee3074f0898aa4dba.tar.gz
build: allow override guile system location
guile has three settings acquired from system: * GUILE_SITE * GUILE_SITE_CCACHE * GUILE_EXTENSION The <guile-2.2 m4 macro exposed only GUILE_SITE while build tried to guess the other variables based on the $libdir of the gnutls which may be different. The >=guile-2.2 m4 macro provides all settings for build to use as default, while allowing to override each. Resolves: #748 Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b4d0db3b51..5be356e2ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,14 @@
# along with this file; if not, write to the Free Software Foundation,
# Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-DISTCHECK_CONFIGURE_FLAGS = --enable-doc --enable-gtk-doc --disable-valgrind-tests AUTOGEN=false
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-doc \
+ --enable-gtk-doc \
+ --disable-valgrind-tests \
+ --with-guile-site-dir='$$(datarootdir)/guile/site/$$(GUILE_EFFECTIVE_VERSION)' \
+ --with-guile-site-ccache-dir='$$(libdir)/guile/$$(GUILE_EFFECTIVE_VERSION)/site-ccache' \
+ --with-guile-extension-dir='$$(libdir)/guile/$$(GUILE_EFFECTIVE_VERSION)/extensions' \
+ AUTOGEN=false
SUBDIRS = gl lib extra