summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2019-01-11 07:23:40 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2019-01-19 07:37:11 +0100
commit4a644cd4237e854399b9c0925d677874f36b456d (patch)
treedcffdd092f7e6fbc23ffd6ca3fd70be4fe32d0b1 /Makefile.am
parentb527be10f829e286130705dfd14f8bb5661e7f35 (diff)
downloadgnutls-4a644cd4237e854399b9c0925d677874f36b456d.tar.gz
auto-generate the AUTHORS filetmp-authors
The original file was unmaintained since long time. This is now auto-generated from the git shortlog, at release time. Relates: #606 Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 57e42359bf..f3944b9366 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,14 @@ ACLOCAL_AMFLAGS = -I m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4 --ins
EXTRA_DIST = cfg.mk maint.mk CONTRIBUTING.md README.md LICENSE AUTHORS NEWS \
ChangeLog THANKS INSTALL.md symbols.last
+DISTCLEANFILES = AUTHORS
+
+AUTHORS:
+ @echo -e "The authors list is autogenerated from the git history; sorted by number of commits\n" >AUTHORS
+ @git shortlog -sen| cut -f 2 | sed 's/@/ at /g' >> AUTHORS
+ @echo -e "\n\nThe translators list is autogenerated from po file history\n" >>AUTHORS
+ @sed -n 's/.*Last-Translator: *\(.*\) *<.*/\1/p' po/*.po | sort -u >>AUTHORS
+
pic-check:
@echo "Checking for position dependent code"
readelf -d $(builddir)/lib/.libs/libgnutls.so|grep TEXTREL; if test $$? = 0;then \
@@ -169,4 +177,4 @@ dist-hook: libopts-check symbol-check
mv ChangeLog $(distdir)
touch $(distdir)/doc/*.html $(distdir)/doc/*.pdf $(distdir)/doc/*.info
-.PHONY: abi-check abi-dump pic-check symbol-check local-code-coverage-output files-update libopts-check
+.PHONY: abi-check abi-dump pic-check symbol-check local-code-coverage-output files-update libopts-check AUTHORS