summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-04-29 13:15:33 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2019-05-03 19:04:10 +0200
commit53200082e55e7cd384fb74ba14da697bbad25153 (patch)
treeac11baa1309eb7e98cdff16fc99d732313bf4bc8 /Makefile.am
parent1ee821191870e425b2e645476b5c311dddb66938 (diff)
downloadgnutls-53200082e55e7cd384fb74ba14da697bbad25153.tar.gz
abi-check: supply --hd2 to abi-check-latest target
To suppress changes in internal structures. Suggested by Nikos Mavrogiannopoulos. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b1aa2e45f0..ffcbc4ee5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,14 +101,14 @@ abi-dump-latest: lib/libgnutls.la libdane/libgnutls-dane.la
abi-check-latest: lib/libgnutls.la libdane/libgnutls-dane.la
@echo "Checking whether the latest ABI dump matches"
- @abidiff --suppressions $(ABIGNORE_FILE) lib/.libs/libgnutls.so $(LIBGNUTLS_ABI_LAST_FILE); if test $$? != 0;then \
+ @abidiff --suppressions $(ABIGNORE_FILE) lib/.libs/libgnutls.so $(LIBGNUTLS_ABI_LAST_FILE) --hd2 "$(srcdir)/lib/includes/gnutls/"; if test $$? != 0;then \
echo "*********************************************************"; \
echo "libgnutls ABI has changed; use 'make-files-update' "; \
echo "and use 'git diff' to check correctness before committing"; \
echo "*********************************************************"; \
false; \
fi
- @abidiff libdane/.libs/libgnutls-dane.so $(LIBDANE_ABI_LAST_FILE); if test $$? != 0;then \
+ @abidiff libdane/.libs/libgnutls-dane.so $(LIBDANE_ABI_LAST_FILE) --hd2 "$(srcdir)/libdane/includes/gnutls/"; if test $$? != 0;then \
echo "*********************************************************"; \
echo "libgnutls-dane ABI has changed; use 'make-files-update' "; \
echo "and use 'git diff' to check correctness before committing"; \