summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2019-11-13 23:47:16 +0300
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2019-12-19 16:31:40 +0300
commit728a34bd150cd662db2eef937d8de904f0883ea9 (patch)
tree989554e119ee8f7ca11232a14336998c82642040 /Makefile.am
parent8d81203c987e717031a6ecfa0a25983f4471d3fc (diff)
downloadgnutls-728a34bd150cd662db2eef937d8de904f0883ea9.tar.gz
abi-check: fix include paths
If GnuTLS is built outside of source tree, abicheck will miss gnutls.h header which is generated in the build tree. Expand arguments to include it. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 405d2fdebf..ae5820c62d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,14 +101,14 @@ abi-dump-latest: lib/libgnutls.la libdane/libgnutls-dane.la
abi-check-latest: lib/libgnutls.la libdane/libgnutls-dane.la
@echo "Checking whether the latest ABI dump matches"
- @abidiff --suppressions $(ABIGNORE_FILE) lib/.libs/libgnutls.so $(LIBGNUTLS_ABI_LAST_FILE) --hd2 "$(srcdir)/lib/includes/gnutls/"; if test $$? != 0;then \
+ @abidiff --suppressions $(ABIGNORE_FILE) lib/.libs/libgnutls.so $(LIBGNUTLS_ABI_LAST_FILE) --hd2 "$(srcdir)/lib/includes/gnutls/" --hd2 $(builddir)/lib/includes/gnutls/ ; if test $$? != 0;then \
echo "*********************************************************"; \
echo "libgnutls ABI has changed; use 'make files-update' "; \
echo "and use 'git diff' to check correctness before committing"; \
echo "*********************************************************"; \
false; \
fi
- @abidiff libdane/.libs/libgnutls-dane.so $(LIBDANE_ABI_LAST_FILE) --hd2 "$(srcdir)/libdane/includes/gnutls/"; if test $$? != 0;then \
+ @abidiff libdane/.libs/libgnutls-dane.so $(LIBDANE_ABI_LAST_FILE) --hd2 "$(srcdir)/libdane/includes/gnutls/" --hd2 $(builddir)/lib/includes/gnutls/; if test $$? != 0;then \
echo "*********************************************************"; \
echo "libgnutls-dane ABI has changed; use 'make files-update' "; \
echo "and use 'git diff' to check correctness before committing"; \
@@ -123,7 +123,7 @@ ABICHECK_COMMON = --no-added-syms
abi-check: lib/libgnutls.la libdane/libgnutls-dane.la
@for file in $$(echo $(srcdir)/devel/libgnutls-*-$$(uname -m).abi);do \
echo "Comparing libgnutls with $$file"; \
- abidiff $${file} lib/.libs/libgnutls.so $(ABICHECK_COMMON) --suppressions $(ABIGNORE_FILE) --hd2 "$(srcdir)/lib/includes/gnutls/"; \
+ abidiff $${file} lib/.libs/libgnutls.so $(ABICHECK_COMMON) --suppressions $(ABIGNORE_FILE) --hd2 "$(srcdir)/lib/includes/gnutls/" --hd2 $(builddir)/lib/includes/gnutls/; \
if test $$? != 0;then \
echo "****************************************************************************"; \
echo "ABI check failed; If intentional add suppression in devel/libgnutls.abignore"; \
@@ -133,7 +133,7 @@ abi-check: lib/libgnutls.la libdane/libgnutls-dane.la
done
@for file in $$(echo $(srcdir)/devel/libdane-*-$$(uname -m).abi);do \
echo "Comparing libgnutls-dane with $$file"; \
- abidiff $${file} libdane/.libs/libgnutls-dane.so $(ABICHECK_COMMON) --hd2 "$(srcdir)/libdane/includes/gnutls/"; \
+ abidiff $${file} libdane/.libs/libgnutls-dane.so $(ABICHECK_COMMON) --hd2 "$(srcdir)/libdane/includes/gnutls/" --hd2 $(builddir)/lib/includes/gnutls/; \
if test $$? != 0;then \
echo "**********************************************"; \
echo "ABI check failed; If intentional add a "; \