summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2008-02-26 10:50:20 +0100
committerSimon Josefsson <simon@josefsson.org>2008-02-26 10:50:20 +0100
commit729bc7c7766b5a30eeee29f22b058ee47ca0a971 (patch)
treef00e011edb603c6d989b00ba8f61ff7f4af05658 /Makefile.am
parent9613dce563ff50ea823de63e07d75b0a1f03ac60 (diff)
downloadgnutls-729bc7c7766b5a30eeee29f22b058ee47ca0a971.tar.gz
Use gnupload.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index d886059900..5c7411dbae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,14 +50,15 @@ release:
cd doc && ../build-aux/gendocs.sh -o ../$(htmldir)/manual/ $(PACKAGE) "GNU TLS"
git commit -m Generated. ChangeLog
git-tag -u b565716f! -m $(VERSION) $(tag)
- git-push --tags
- git-push
+ cp -v $(distdir).tar.bz2 $(distdir).tar.bz2.sig $(htmldir)/releases/
+ cp -v doc/reference/html/*.html doc/reference/html/*.png doc/reference/html/*.css doc/reference/html/*.devhelp $(htmldir)/reference/
gpg -b $(distdir).tar.bz2
gpg --verify $(distdir).tar.bz2.sig
+ git-push --tags
+ git-push
scp $(distdir).tar.bz2 $(distdir).tar.bz2.sig igloo.linux.gr:~ftp/pub/gnutls/devel/
ssh igloo.linux.gr 'cd ~ftp/pub/gnutls/devel/ && sha1sum *.tar.bz2 > CHECKSUMS'
- cp -v $(distdir).tar.bz2 $(distdir).tar.bz2.sig $(htmldir)/releases/
- cp -v doc/reference/html/*.html doc/reference/html/*.png doc/reference/html/*.css doc/reference/html/*.devhelp $(htmldir)/reference/
+ build-aux/gnupload --to alpha.gnu.org:gnutls $(distdir).tar.gz
cd $(htmldir) && \
cvs add -kb releases/$(distdir).tar.bz2 \
releases/$(distdir).tar.bz2.sig && \