summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2007-10-29 11:58:14 +0100
committerSimon Josefsson <simon@josefsson.org>2007-10-29 11:58:14 +0100
commitd1305a70f7e914df9f506ffb4ebfcce2cbe8d0c6 (patch)
tree6c36e93abf39dedfa3279cc379d982590e53e22b /Makefile.am
parenta390eea4a06a2d27ba91e75caafeb484641961e8 (diff)
downloadgnutls-d1305a70f7e914df9f506ffb4ebfcce2cbe8d0c6.tar.gz
Reorder release target, to do disconnected ops first, and to avoid losing tags.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f1d1b4df43..aa4388603d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,13 +47,14 @@ release:
! git-tag -l $(tag) | grep $(PACKAGE) > /dev/null
rm -f ChangeLog
$(MAKE) ChangeLog distcheck
+ cd doc && ../build-aux/gendocs.sh -o ../$(htmldir)/manual/ $(PACKAGE) "GNU TLS"
git commit -m Generated. ChangeLog
git-tag -u b565716f! -m $(VERSION) $(tag)
+ git-push --tags
gpg -b $(distdir).tar.bz2
gpg --verify $(distdir).tar.bz2.sig
scp $(distdir).tar.bz2{,.sig} igloo.linux.gr:~ftp/pub/gnutls/devel/
ssh igloo.linux.gr 'cd ~ftp/pub/gnutls/devel/ && sha1sum *.tar.bz2 > CHECKSUMS'
- cd doc && ../build-aux/gendocs.sh -o ../$(htmldir)/manual/ $(PACKAGE) "GNU TLS"
cp -v $(distdir).tar.bz2{,.sig} $(htmldir)/releases/
cp -v doc/reference/html/*.{html,png,css,devhelp} $(htmldir)/reference/
cd $(htmldir) && cvs add -kb releases/$(distdir).tar.bz2{,.sig} && \