summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2012-01-31 01:22:09 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2012-01-31 01:31:09 +0100
commit4dbfdd7287f098aa274ebd4f6e256f51679ced08 (patch)
treedb3c8bdadd78aee9397da814a9f5aeea3bb5d34e /Makefile.am
parent7e7e8029a2ec9650a1020442907bb81fd31f98e3 (diff)
downloadgnutls-4dbfdd7287f098aa274ebd4f6e256f51679ced08.tar.gz
replacing the version is not enough. Regenerate all files depending on .dep on dist-hook.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ed8cc04cf3..4fdae7178e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,3 +42,13 @@ dist-hook:
make ChangeLog
cp -f ChangeLog $(distdir)/
sed 's/\@VERSION\@/$(VERSION)/g' -i $(distdir)/src/*.def
+ cd $(distdir)/src/ && for i in *.def;do \
+ autogen $$i; \
+ autogen -Tagtexi-cmd.tpl $$i; \
+ cp $$i $$i.tmp; \
+ sed -i 's/@subheading \(.*\)/@*\n@var{\1}\n@*/' $$i.tmp; \
+ autogen -Tagman-cmd.tpl $$i.tmp; \
+ rm -f $$i.tmp; \
+ mv -f *.1 ../doc/manpages/; \
+ mv -f *.texi ../doc/manpages; \
+ done