summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2015-08-10 16:43:28 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2015-08-10 16:44:17 +0200
commitc6816015ff2ff1c8932ab768455b3fdffff6cd5b (patch)
tree95f81a00ec6f9942fe4f6673f9b63b0c5a15d99e /Makefile.am
parent90ff2c0527e43b1c84b13a6c30a6b06d37628b41 (diff)
downloadgnutls-c6816015ff2ff1c8932ab768455b3fdffff6cd5b.tar.gz
before dist ensure that included libopts matches autogen
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2d6f1a4d28..d446711472 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,4 +73,9 @@ dist-hook:
cd $(distdir)/src/ && for i in *-args.c *-args.h;do \
mv $$i $$i.bak; \
done
+ @echo "*****************************************************************"
+ @echo "Checking whether included libopts matches the system's. If the"
+ @echo "check fails upgrade the included libopts."
+ @echo "*****************************************************************"
+ test "`autoopts-config libsrc|cut -d '-' -f 2|sed 's/.tar.gz//'`" = "`cat src/libopts/autoopts/options.h |grep OPTIONS_VERSION_STRING|cut -d '"' -f 2|sed 's/:/./g'`"
touch $(distdir)/doc/*.html $(distdir)/doc/*.pdf $(distdir)/doc/*.info