summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2017-05-09 20:57:00 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2017-05-10 10:37:18 +0200
commit3571a2cb87ac7b8580a74fa45a4db2a908f1326e (patch)
tree39bac1cd47be2097ef1213538d6c169d310f5ec5 /Makefile.am
parentd82a574d145a41dc9c9bc28e7f6ed24c402349f8 (diff)
downloadgnutls-3571a2cb87ac7b8580a74fa45a4db2a908f1326e.tar.gz
Makefile: files-update directive will update the auto-generated files in src/
This simplifies the update of files generated by autogen. Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 16 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index daecb37d72..dafaa6dbea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -112,15 +112,28 @@ symbol-check:
local-code-coverage-output: code-coverage-capture
cat GnuTLS-$(VERSION)-coverage/index.html|grep headerCovTableEntryLo|head -1|sed 's/^.*>\([0-9]\+\.[0-9]\+\s*%\)<.*$$/ coverage lines: \1/' || true
-files-update:
+libopts-check:
+ @echo "*****************************************************************"
+ @echo "Checking whether included libopts matches the system's. If the"
+ @echo "check fails upgrade the included libopts."
+ @echo "*****************************************************************"
+ test "`autoopts-config libsrc|cut -d '-' -f 2|sed 's/.tar.gz//'`" = "`cat src/libopts/autoopts/options.h |grep OPTIONS_VERSION_STRING|cut -d '"' -f 2|sed 's/:/./g'`"
+
+files-update: libopts-check
make -C doc/ compare-makefile || mv doc/tmp-compare-makefile doc/Makefile.am
make -C doc/manpages compare-makefile || mv doc/manpages/tmp-compare-makefile doc/manpages/Makefile.am
make -C . symbol-check || mv symbols.last.tmp symbols.last
@echo "******************************************************************************************"
+ @echo "updating autogen files in src/"
+ @echo "******************************************************************************************"
+ cd $(srcdir)/src/ && for i in *-args.c *-args.h;do \
+ test -h $$i || cp $$i $$i.bak; \
+ done
+ @echo "******************************************************************************************"
@echo "updated auto-generated files; please use git diff to verify the correctness of the changes"
@echo "******************************************************************************************"
-dist-hook: symbol-check abi-check
+dist-hook: libopts-check symbol-check abi-check
make -C doc/ compare-makefile
make -C doc/ compare-exported
make -C doc/manpages compare-makefile
@@ -142,11 +155,6 @@ dist-hook: symbol-check abi-check
cd $(distdir)/src/ && for i in *-args.c *-args.h;do \
mv $$i $$i.bak; \
done
- @echo "*****************************************************************"
- @echo "Checking whether included libopts matches the system's. If the"
- @echo "check fails upgrade the included libopts."
- @echo "*****************************************************************"
- test "`autoopts-config libsrc|cut -d '-' -f 2|sed 's/.tar.gz//'`" = "`cat src/libopts/autoopts/options.h |grep OPTIONS_VERSION_STRING|cut -d '"' -f 2|sed 's/:/./g'`"
touch $(distdir)/doc/*.html $(distdir)/doc/*.pdf $(distdir)/doc/*.info
-.PHONY: abi-check
+.PHONY: abi-check pic-check libopts-check symbol-check