summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-04-12 14:21:04 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-04-12 14:55:15 +0200
commitac670b2b4c8336c6d2d67322d928ec6b6c576be6 (patch)
tree2e913bc20374a18dbd24b221bfaa01bc2b6b9d0c /Makefile.am
parenta4fd1120e9c9b237047086f798fab8ffc60b759e (diff)
downloadgnutls-ac670b2b4c8336c6d2d67322d928ec6b6c576be6.tar.gz
configure: Add a code coverage option
Configure with: ./configure --enable-code-coverage Show coverage output with: make && make check && make code-coverage-capture
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c013caac2..5564c9189d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,6 +80,8 @@ abi-check:
test ! -f "$(srcdir)/devel/ABI-dane-$$(uname -m).dump" || abi-compliance-checker -abi -lib gnutls-dane -old "$(srcdir)/devel/ABI-dane-$$(uname -m).dump" -new $(TMPFILE)
@rm -f $(TMPFILE)
+@CODE_COVERAGE_RULES@
+
dist-hook: abi-check
make -C doc/ compare-makefile
make -C doc/ compare-exported