summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2019-05-30 14:42:52 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2019-05-30 14:42:55 +0200
commit4b3d723f3a33e7131370d4c6bd69dd492a37044d (patch)
tree4d38efefa1de2e3e7d362b3d7b3d0c180ea1edfc /Makefile.am
parent98590fe57ba10372036f97fe0ff3c93220bca13c (diff)
downloadgnutls-4b3d723f3a33e7131370d4c6bd69dd492a37044d.tar.gz
Makefile.am: do not create files when it shouldn't
If a pdf or html file is not distributed, previously `make dist` would create a file called '*.pdf' which did not make sense. This addresses this problem. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ffcbc4ee5d..f3b203146f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -204,6 +204,6 @@ dist-hook: libopts-check
$(MAKE) -C doc/manpages compare-makefile
$(MAKE) ChangeLog
mv ChangeLog $(distdir)
- touch $(distdir)/doc/*.html $(distdir)/doc/*.pdf $(distdir)/doc/*.info
+ touch -c $(distdir)/doc/*.html $(distdir)/doc/*.pdf $(distdir)/doc/*.info
.PHONY: abi-check abi-dump-versioned abi-dump-latest pic-check symbol-check local-code-coverage-output files-update libopts-check AUTHORS