summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2021-05-29 06:56:57 +0200
committerDaiki Ueno <ueno@gnu.org>2021-05-29 08:37:54 +0200
commitc58e0c265d0fcbd61e651703da0875ad526cba98 (patch)
treeac1dd9d12b4ec8bae485d1d1bce88e2b30c4779e /Makefile.am
parente2181120121d1ee6c1fc0e553549ad4598551402 (diff)
downloadgnutls-c58e0c265d0fcbd61e651703da0875ad526cba98.tar.gz
AUTHORS: take into account of Co-authored-by:
Signed-off-by: Daiki Ueno <ueno@gnu.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index ae5820c62d..80cb64a113 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,15 +60,17 @@ endif
ACLOCAL_AMFLAGS = -I m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4 --install
EXTRA_DIST = cfg.mk maint.mk CONTRIBUTING.md README.md LICENSE AUTHORS NEWS \
- ChangeLog THANKS INSTALL.md RELEASES.md
+ ChangeLog THANKS INSTALL.md RELEASES.md .mailmap
DISTCLEANFILES = AUTHORS
-AUTHORS:
- @echo -e "The authors list is autogenerated from the git history; sorted by number of commits\n" >AUTHORS
- @git shortlog -sen| cut -f 2 | sed 's/@/ at /g' >> AUTHORS
- @echo -e "\n\nThe translators list is autogenerated from po file history\n" >>AUTHORS
- @sed -n 's/.*Last-Translator: *\(.*\) *<.*/\1/p' po/*.po | sort -u >>AUTHORS
+AUTHORS: Makefile.am .mailmap
+ $(AM_V_GEN) { \
+ echo -e "The authors list is autogenerated from the git history; sorted by number of commits\n"; \
+ git shortlog -sen --no-merges --group author --group trailer:co-authored-by | cut -f 2 | sed 's/@/ at /g'; \
+ echo -e "\n\nThe translators list is autogenerated from po file history\n"; \
+ sed -n 's/.*Last-Translator: *\(.*\) *<.*/\1/p' po/*.po | sort -u; \
+ } > $@-t && mv $@-t $@
pic-check:
@echo "Checking for position dependent code"