summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2018-05-07 08:12:12 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2018-05-09 21:44:33 +0200
commitccb03b58d36f279fa7cc71d2b81af4dfbfb3d513 (patch)
treecc98447610cf3f80a5dd641641d4884fe088ab12 /Makefile.am
parent0653c1561168ca43445bf027a3e57827890c06d0 (diff)
downloadgnutls-ccb03b58d36f279fa7cc71d2b81af4dfbfb3d513.tar.gz
Makefile.am: optimized the abi-check configure step
Also ensured that the same build flags are applied in both builds for ABI checking. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2269637acd..8638bd8501 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -76,8 +76,11 @@ ABIVER=$(shell git for-each-ref --sort=taggerdate --format '%(refname)' refs/tag
@echo "Creating ABI for $(ABIVER)"
cd $(ABI_TMPCLONEDIR) && \
git checkout $(ABIREF) && \
- make autoreconf && CFLAGS="-g -Og" ./configure --disable-doc && \
- $(MAKE) -j$$(nproc) -C gl && $(MAKE) -j$$(nproc) -C lib && $(MAKE) -j$$(nproc) -C libdane
+ make autoreconf && if test -f ../cache/config.cache;then\
+ CFLAGS="-g -Og" ./configure --disable-doc --cache-file ../cache/config.cache;\
+ else\
+ CFLAGS="-g -Og" ./configure --disable-doc;\
+ fi && $(MAKE) -j$$(nproc) -C gl && $(MAKE) -j$$(nproc) -C lib && $(MAKE) -j$$(nproc) -C libdane
touch $@
abi-check: .prev-tag-abi.stamp