summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-09-15 16:49:37 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-09-15 16:49:39 +0200
commite2f23b4397a5fd50f256d1f1f71cf726b56d7085 (patch)
tree3cabf4f7e4344fe3930d56d2aaffe0aa565a32cf /Makefile.am
parent87bb64b5f3e88a2577a03ac12252aa1c48480633 (diff)
downloadgnutls-e2f23b4397a5fd50f256d1f1f71cf726b56d7085.tar.gz
Makefile: abi-check no longer require gnutls headers to be installed
This addresses the issue of requiring gnutls-devel in the CI system to run abi-check.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d4c313b126..3cc1e7ce2e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,7 +75,9 @@ abi-check:
abi-compliance-checker -abi -lib gnutls -old "$(srcdir)/devel/ABI-$$(uname -m).dump" -new $(TMPFILE) -skip-symbols $(srcdir)/devel/abi-unchecked-symbols
@echo "Checking libgnutls-dane ABI"
@echo "<version>$(VERSION)</version>" >$(TMPFILE)
- @echo "<headers>$(srcdir)/libdane/includes/gnutls</headers>" >>$(TMPFILE)
+ @echo "<headers>$(srcdir)/libdane/includes/gnutls" >>$(TMPFILE)
+ @echo "$(srcdir)/lib/includes/gnutls" >>$(TMPFILE)
+ @echo "$(builddir)/lib/includes/gnutls</headers>" >>$(TMPFILE)
@echo "<libs>$(builddir)/libdane/.libs</libs>" >>$(TMPFILE)
test ! -f "$(srcdir)/devel/ABI-dane-$$(uname -m).dump" || abi-compliance-checker -abi -lib gnutls-dane -old "$(srcdir)/devel/ABI-dane-$$(uname -m).dump" -new $(TMPFILE)
@rm -f $(TMPFILE)