summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2009-11-29 00:11:12 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2009-11-29 01:08:05 +0200
commit0477fd0883cbd9cd9809c3b8029ce146187b5431 (patch)
tree197ec8f844aee340bc79b842a3a400eed3aecaa5 /configure.ac
parent02ee5842f8f5f37ee93e258d5edfc2560b00ac2c (diff)
downloadgnutls-0477fd0883cbd9cd9809c3b8029ce146187b5431.tar.gz
Added cryptodev support (/dev/crypto). Tested with http://www.logix.cz/michal/devel/cryptodev/.
Added benchmark utility for AES. Exported API to access encryption algorithms.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 80a1e9b631..60668e955c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -187,6 +187,21 @@ LIBS=$SAVED_LIBS
AC_MSG_CHECKING([whether to use the included libcfg])
AC_MSG_RESULT($libcfg_enabled)
+# For cryptodev
+enable_cryptodev=no
+AC_MSG_CHECKING([whether to add cryptodev support])
+AC_ARG_ENABLE(cryptodev,
+ AS_HELP_STRING([--enable-cryptodev], [enable cryptodev support]),
+enable_cryptodev=yes)
+AC_MSG_RESULT($enable_cryptodev)
+
+if test "$enable_cryptodev" = "yes"; then
+AC_CHECK_MEMBER(struct crypt_opv.iovec,
+[AC_DEFINE([ENABLE_CRYPTODEV_IOVEC], 1, [Enable cryptodev iovec support])],,[[#include <crypto/cryptodev.h>]])
+AC_DEFINE([ENABLE_CRYPTODEV], 1, [Enable cryptodev support])
+fi
+
+
AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
@@ -303,4 +318,5 @@ AC_MSG_NOTICE([summary of build options:
Guile wrappers: $opt_guile_bindings
C++ library: $use_cxx
OpenSSL library: $enable_openssl
+ /dev/crypto: $enable_cryptodev
])