summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2018-08-07 16:27:19 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2018-08-08 16:32:19 +0200
commit1f6a8edbc451f9fec0cbbf281673a0ef67c3fbdd (patch)
tree9f50ac6c9b68d8677744d3e7b565378927578886 /configure.ac
parent3aeb9c1443f74ee1107772608afbc1041d65c958 (diff)
downloadgnutls-1f6a8edbc451f9fec0cbbf281673a0ef67c3fbdd.tar.gz
gnutls_memset: use explicit_bzero
That is, use the glibc function when available and the second parameter is zero. Resolves #230 Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9e16a5cd07..3001d212e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -293,7 +293,7 @@ AC_C_BIGENDIAN
dnl No fork on MinGW, disable some self-tests until we fix them.
dnl Check clock_gettime and pthread_mutex_lock in libc (avoid linking to other libs)
-AC_CHECK_FUNCS([fork setitimer inet_ntop inet_pton getrusage getpwuid_r nanosleep daemon getpid localtime vasprintf mmap],,)
+AC_CHECK_FUNCS([fork setitimer inet_ntop inet_pton getrusage getpwuid_r nanosleep daemon getpid localtime vasprintf mmap explicit_bzero],,)
dnl Manually check some functions by including headers first. On macOS, you
dnl normally only have the latest SDK available, containing all existing
dnl functions, but having them restricted according to target version in