summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFiona Klute <fiona.klute@gmx.de>2020-06-16 20:48:44 +0200
committerFiona Klute <fiona.klute@gmx.de>2020-06-16 21:06:16 +0200
commit183b0e482302c2c61479414f96e22213f5f88dd4 (patch)
treeb4ed9791090e0d4a7f3f93b042c7435007d77291 /configure.ac
parent1c8720d012d47439e96672ea44f34e50ae8c6725 (diff)
downloadgnutls-183b0e482302c2c61479414f96e22213f5f88dd4.tar.gz
Detect Python interpreter instead of assuming "python"
This makes the extended test suite work one Debian(-ish) systems without Python 2, where the Python 3 interpreter is called "python3". Signed-off-by: Fiona Klute <fiona.klute@gmx.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f7766f38f2..a46d85d070 100644
--- a/configure.ac
+++ b/configure.ac
@@ -462,6 +462,9 @@ fi
AM_CONDITIONAL(WANT_TEST_SUITE, test "$full_test_suite" = "yes")
+# parts of the extended test suite use Python
+AM_PATH_PYTHON(,, [:])
+
AC_ARG_ENABLE(oldgnutls-interop,
AS_HELP_STRING([--enable-oldgnutls-interop], [enable interoperability testing with old gnutls version]),
enable_oldgnutls_interop=$enableval, enable_oldgnutls_interop=no)