summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-11 21:30:48 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-11 21:30:48 +0100
commit676ae412aeea58fa2c6aa7960ec16223101556eb (patch)
tree779188b38288281a80ebef78674bd8d89aa86426 /configure.ac
parent3d4928e4268bea40a37e796795e42353d4415a6d (diff)
downloadgnutls-676ae412aeea58fa2c6aa7960ec16223101556eb.tar.gz
guile: Do not attempt to load shared object when cross-compiling.
Reported by Helmut Grohne <helmut@subdivi.de> and Andreas Metzler <ametzler@bebt.de> at <https://bugs.debian.org/943905>. * configure.ac: Add 'CROSS_COMPILING' conditional. * guile/Makefile.am (CROSS_COMPILING_VARIABLE): New variable. (%.go): Use it. * guile/modules/gnutls.in <top level>: Do not call 'load-extension' when "GNUTLS_GUILE_CROSS_COMPILING" is defined. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 73c560406e..30dd517437 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1000,6 +1000,7 @@ fi
AM_CONDITIONAL([HAVE_GUILE], [test "$opt_guile_bindings" = "yes"])
AM_CONDITIONAL([HAVE_GUILD], [test "x$GUILD" != "x"])
+AM_CONDITIONAL([CROSS_COMPILING], [test "x$cross_compiling" = "xyes"])
LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBS"
LIBGNUTLS_CFLAGS="-I${includedir}"