summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-11-08 10:10:09 +0100
committerDaiki Ueno <dueno@redhat.com>2019-11-08 10:10:09 +0100
commit98ac6220bdef67ba1153dc515613e4582e1419a2 (patch)
treecf277c9961388fa1d5cb3d025760c92a432e0ccc /configure.ac
parent1c2135506825ae80966fe2797613806916b7e3c0 (diff)
downloadgnutls-98ac6220bdef67ba1153dc515613e4582e1419a2.tar.gz
nettle: use included CFB8 implementation if nettle is 3.5
Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e7a8ece55..73c560406e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -597,6 +597,14 @@ AC_CHECK_FUNCS(nettle_rsa_sec_decrypt,
LIBS=$save_LIBS
# Check if nettle has CFB8 support
+if test -z "$ac_cv_func_nettle_cfb8_encrypt"; then
+ # nettle_cfb8_decrypt in nettle 3.5 is known to be broken
+ ver=`$PKG_CONFIG --modversion nettle`
+ if expr "$ver" : '^3\.5\b' >/dev/null; then
+ ac_cv_func_nettle_cfb8_encrypt=no
+ fi
+fi
+
save_LIBS=$LIBS
LIBS="$LIBS $NETTLE_LIBS"
AC_CHECK_FUNCS(nettle_cfb8_encrypt)