summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2020-01-02 14:09:50 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2020-01-03 09:43:24 +0100
commitf0b41c5dc29f2715beed7ee93a62de65bcfc26d8 (patch)
tree30a00ff81896d09679b61776f65b6f2d9147e627 /configure.ac
parentacb025f0d20cda0e2173c822e7d4efa611cce396 (diff)
downloadgnutls-f0b41c5dc29f2715beed7ee93a62de65bcfc26d8.tar.gz
ecore cli: updated and rewritten to use libev
That removes a lot of code that was not necessary in the gnutls test suite. Resolves: #884 Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2ac620688d..8aa72f443b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -433,7 +433,7 @@ AC_ARG_ENABLE(full-test-suite,
# test if we are in git master or in release build. In release
# builds we do not use valgrind.
-SUITE_FILE="${srcdir}/tests/suite/mini-eagain2.c"
+SUITE_FILE="${srcdir}/tests/suite/prime-check.c"
if test "$full_test_suite" = yes && test ! -f "$SUITE_FILE";then
full_test_suite=no
fi
@@ -450,6 +450,16 @@ fi
AM_CONDITIONAL(ENABLE_OLDGNUTLS_INTEROP, test "$enable_oldgnutls_interop" != "no")
+# check for libev - used in full test suite
+AC_LIB_HAVE_LINKFLAGS(ev,, [#include <ev.h>], [ev_run(0,0);])
+if test "$ac_cv_libev" = yes; then
+ AC_SUBST([LIBEV_LIBS], [$LIBEV])
+elif test "$full_test_suite" = yes;then
+ AC_MSG_ERROR([[***
+*** libev4 was not found.
+***]])
+fi
+
dnl GCC warnings to enable
AC_ARG_ENABLE([gcc-warnings],