summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2009-05-17 10:38:37 +0200
committerSimon Josefsson <simon@josefsson.org>2009-05-17 10:38:37 +0200
commit4f155e7109699fdf98683549e48142f018f6546e (patch)
treec504369209d9d8814f75e0bc9e395e71a9f81b23 /configure.ac
parent4ed17272e4b6f6901cb65f46436a6adddea9f13c (diff)
downloadgnutls-4f155e7109699fdf98683549e48142f018f6546e.tar.gz
Need to run AC_PROG_CXX unconditionally.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2b5b2028f8..4bfe58a7dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,11 +50,12 @@ fi
gl_EARLY
AC_C_INLINE
+# For the C++ code
+AC_PROG_CXX
AC_ARG_ENABLE(cxx,
AS_HELP_STRING([--disable-cxx], [unconditionally disable the C++ library]),
use_cxx=$enableval, use_cxx=yes)
if test "$use_cxx" != "no"; then
- AC_PROG_CXX
AC_LANG_PUSH(C++)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])], use_cxx=yes, use_cxx=no)
AC_LANG_POP(C++)