summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2012-05-25 23:44:15 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2012-05-26 00:48:49 +0200
commit16b03a96fa864e1bba5c28f1a1bd6846163ac6b2 (patch)
treed5d2f0480515a4b6f113e27db8fff3cf0b8af9cd /configure.ac
parentd869e863c32d685d7e795616db4e6e6bf4fa1d22 (diff)
downloadgnutls-16b03a96fa864e1bba5c28f1a1bd6846163ac6b2.tar.gz
Added the notion of a default CRL file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b0fa3ae518..e7316d3f60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -296,6 +296,10 @@ AC_ARG_WITH([default-trust-store-file],
[AS_HELP_STRING([--with-default-trust-store-file=FILE],
[use the given file default trust store])])
+AC_ARG_WITH([default-crl-file],
+ [AS_HELP_STRING([--with-default-crl-file=FILE],
+ [use the given CRL file as default])])
+
if test "x$with_default_trust_store_pkcs11" = x -a "x$with_default_trust_store_file" = x; then
# auto detect http://lists.gnu.org/archive/html/help-gnutls/2012-05/msg00004.html
for i in \
@@ -315,6 +319,11 @@ if test "x$with_default_trust_store_file" != x; then
["$with_default_trust_store_file"], [use the given file default trust store])
fi
+if test "x$with_default_crl_file" != x; then
+ AC_DEFINE_UNQUOTED([DEFAULT_CRL_FILE],
+ ["$with_default_crl_file"], [use the given CRL file])
+fi
+
dnl Guile bindings.
opt_guile_bindings=yes
AC_MSG_CHECKING([whether building Guile bindings])
@@ -548,8 +557,10 @@ if features are disabled)
SRP support: $ac_enable_srp
PSK support: $ac_enable_psk
Anon auth support:$ac_enable_anon
+
Trust store pkcs: $with_default_trust_store_pkcs11
Trust store file: $with_default_trust_store_file
+ CRL file: $with_default_crl_file
])
AC_MSG_NOTICE([Optional applications: