summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-13 14:20:50 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-11-14 03:17:21 +0100
commit4029def5fdf073fa0696dfd52ef496c0ec475f31 (patch)
tree27b9cb48590819635a2f2074203b9d50386ece02 /configure.ac
parentb2177b7fbd76599a26d5fca657c09cd351ff63ba (diff)
downloadgnutls-4029def5fdf073fa0696dfd52ef496c0ec475f31.tar.gz
print whether the local libopts or libtasn1 are being used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 56df617fbb..06b3327d89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -343,6 +343,7 @@ fi
AM_CONDITIONAL(ENABLE_TROUSERS, test "$with_tpm" != "no")
+ac_enable_local_libopts=yes
LIBOPTS_CHECK([src/libopts])
if test "$NEED_LIBOPTS_DIR" != "true";then
dnl delete libopts-generated files
@@ -353,6 +354,7 @@ if test "$NEED_LIBOPTS_DIR" != "true";then
fi
done
AC_SUBST([AUTOGEN], [/bin/true])
+ ac_enable_local_libopts=no
fi
AC_CHECK_TYPE(ssize_t,
@@ -710,7 +712,8 @@ if features are disabled)
AC_MSG_NOTICE([Optional applications:
crywrap app: $libidn
- libopts flags: ${LIBOPTS_LDADD}
+ local libopts: ${ac_enable_local_libopts}
+ local libtasn1: ${included_libtasn1}
])
AC_MSG_NOTICE([Optional libraries: