summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2012-09-21 00:55:05 +0200
committerSimon Josefsson <simon@josefsson.org>2012-09-21 00:55:05 +0200
commit7feebc365756ee1e8d98db1d1b1728ec96c6e688 (patch)
tree79c852beefcb22e676e1279bf2c3dcfb2a5fd355 /configure.ac
parentb0680b7566709eaed6fb5192180702292266e335 (diff)
downloadgnutls-7feebc365756ee1e8d98db1d1b1728ec96c6e688.tar.gz
Cleanup warning flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 756224244c..d3bec26892 100644
--- a/configure.ac
+++ b/configure.ac
@@ -279,6 +279,11 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wstrict-overflow"
nw="$nw -Wmissing-noreturn"
nw="$nw -Winline" # Too compiler dependent
+ nw="$nw -Wsuggest-attribute=pure" # Is it worth using attributes?
+ nw="$nw -Wsuggest-attribute=const" # Is it worth using attributes?
+ nw="$nw -Wsuggest-attribute=noreturn" # Is it worth using attributes?
+ nw="$nw -Wstack-protector" # Some functions cannot be protected
+ nw="$nw -Wredundant-decls" # Some files cannot be compiled with that (gl_fd_to_handle)
gl_MANYWARN_ALL_GCC([ws])
gl_MANYWARN_COMPLEMENT(ws, [$ws], [$nw])
@@ -288,16 +293,11 @@ if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([-Wno-missing-field-initializers]) # We need this one
gl_WARN_ADD([-Wno-format-y2k]) # Too many warnings for now
- gl_WARN_ADD([-Wno-suggest-attribute=pure]) # Too many warnings for now
- gl_WARN_ADD([-Wno-suggest-attribute=const]) # Too many warnings for now
- gl_WARN_ADD([-Wno-suggest-attribute=noreturn]) # Too many warnings for now
gl_WARN_ADD([-Wno-unused-value]) # warnings for things we don't want to get
gl_WARN_ADD([-Wno-unused-result]) # warnings for things we don't want to get
gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
- gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
gl_WARN_ADD([-Wno-stack-protector]) # Some functions cannot be protected
gl_WARN_ADD([-Wno-int-to-pointer-cast]) # Some files cannot be compiled with that (gl_fd_to_handle)
- gl_WARN_ADD([-Wno-redundant-decls]) # Some files cannot be compiled with that (gl_fd_to_handle)
gl_WARN_ADD([-fdiagnostics-show-option])
fi