summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2013-11-05 20:48:53 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-11-05 20:48:53 +0100
commitb9441c29cd0c30870cb500424ac958484fc45a5a (patch)
treeedab5bfef733a7b944f7f9533143e48ffaea50c3 /configure.ac
parentdd3b8202d714009897a857d0d0b8b95e2d37118f (diff)
downloadgnutls-b9441c29cd0c30870cb500424ac958484fc45a5a.tar.gz
If autogen and libopts are present then use the system's libopts.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6b0b290d2c..bc9ba4aa39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,15 @@ gl_EARLY
AM_PROG_AS
AM_PROG_AR
AC_PROG_CXX
+AC_CHECK_PROG([AUTOGEN], [autogen], [autogen], [/bin/true])
+
+if test x"$AUTOGEN" = "x/bin/true"; then
+ AC_MSG_WARN([[
+***
+*** autogen not found. Will not link against libopts.
+*** ]])
+NEED_LIBOPTS_DIR=true
+fi
# For includes/gnutls/gnutls.h.in.
AC_SUBST(MAJOR_VERSION, `echo $PACKAGE_VERSION | sed 's/\(.*\)\..*\..*/\1/g'`)
@@ -334,10 +343,6 @@ fi
AM_CONDITIONAL(ENABLE_TROUSERS, test "$with_tpm" != "no")
-enable_local_libopts=yes
-dnl PKG_CHECK_MODULES([autoopts], autoopts >= 36.2.11,, [enable_local_libopts=yes])
-
-NEED_LIBOPTS_DIR=true
LIBOPTS_CHECK([src/libopts])
AC_CHECK_TYPE(ssize_t,