summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2013-03-05 22:58:57 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-03-05 22:58:57 +0100
commitb251966bdec85f036dc31f30414dc9aa78b5fa89 (patch)
tree8a69d08e9125a34907b88b0f0367e0cf46ac1122 /configure.ac
parent018bc4482aba3c5fb465508cbe11eed802ee6f88 (diff)
downloadgnutls-b251966bdec85f036dc31f30414dc9aa78b5fa89.tar.gz
When cross compiling do not check for ca certificates.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a9cd349325..319e3cbcf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -370,7 +370,8 @@ dnl auto detect http://lists.gnu.org/archive/html/help-gnutls/2012-05/msg00004.h
AC_ARG_WITH([default-trust-store-file],
[AS_HELP_STRING([--with-default-trust-store-file=FILE],
[use the given file default trust store])], with_default_trust_store_file="$withval",
- [for i in \
+ [if test "$target_cpu" = "$host_cpu";then
+ for i in \
/etc/ssl/certs/ca-certificates.crt \
/etc/pki/tls/cert.pem \
/usr/local/share/certs/ca-root-nss.crt \
@@ -380,7 +381,8 @@ AC_ARG_WITH([default-trust-store-file],
with_default_trust_store_file="$i"
break
fi
- done]
+ done
+ fi]
)
if test "$with_default_trust_store_file" = "no";then