summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2014-08-29 12:00:33 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2014-08-29 12:04:31 +0200
commit73fd27ca7942843744997272a22a6eb769e140eb (patch)
tree9767bb43ca02c1661387e20a3fe3786f70f570fb /configure.ac
parent99e0796ea55f6d6ca8d80e525e0c59f6a169d0e3 (diff)
downloadgnutls-73fd27ca7942843744997272a22a6eb769e140eb.tar.gz
added configuration option --disable-padlock
That allows keeping hardware acceleration in x86 but without support for padlock.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 786f98054f..613f2c513d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,6 +117,15 @@ esac
fi
+AC_ARG_ENABLE(padlock,
+ AS_HELP_STRING([--disable-padlock], [unconditionally disable padlock acceleration]),
+ use_padlock=$enableval, use_padlock=yes)
+
+if test "$use_padlock" != "no"; then
+ AC_DEFINE([ENABLE_PADLOCK], 1, [Enable padlock acceleration])
+ AC_SUBST([ENABLE_PADLOCK])
+fi
+AM_CONDITIONAL(ENABLE_PADLOCK, test "$use_padlock" = "yes")
AM_CONDITIONAL(ASM_X86_64, test x"$hw_accel" = x"x86-64")
AM_CONDITIONAL(ASM_X86_32, test x"$hw_accel" = x"x86")
AM_CONDITIONAL(ASM_X86, test x"$hw_accel" = x"x86" || test x"$hw_accel" = x"x86-64")
@@ -791,6 +800,7 @@ AC_MSG_NOTICE([External hardware support:
/dev/crypto: $enable_cryptodev
Hardware accel: $hw_accel
+ Padlock accel: $use_padlock
PKCS#11 support: $with_p11_kit
TPM support: $with_tpm
])