summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-27 10:38:22 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-27 10:44:17 +0100
commit8c203369c896b400eea2c4505438b44f2e831f23 (patch)
tree1a6d0a70965b6913e71300834733138b49b04bdc /configure.ac
parent5335b36851cdfb6f684935cd42a1b88e2f754a77 (diff)
downloadgnutls-8c203369c896b400eea2c4505438b44f2e831f23.tar.gz
check for alternative unbound root key files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bf7f8dac1b..c584725a57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -287,7 +287,11 @@ AC_ARG_WITH(unbound-root-key-file, AS_HELP_STRING([--with-unbound-root-key-file]
if test "$have_win" = yes; then
unbound_root_key_file="C:\\Program Files\\Unbound\\root.key"
else
- unbound_root_key_file="/etc/unbound/root.key"
+ if test -f /var/lib/unbound/root.key;then
+ unbound_root_key_file="/var/lib/unbound/root.key"
+ else
+ unbound_root_key_file="/etc/unbound/root.key"
+ fi
fi
)