summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2015-04-20 23:39:08 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2015-04-20 23:49:07 +0200
commit7b095de6bd51a7b640bf4c769119b10bf8c289fd (patch)
tree25ea3d47a3277e2d2ac774a0725e67ed1cca72a2 /configure.ac
parent7ae73db8bd74f0232580830f28f30710b6c163f7 (diff)
downloadgnutls-7b095de6bd51a7b640bf4c769119b10bf8c289fd.tar.gz
libopts: fixed the reading of the --enable-local-libopts flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7c454cd9f5..185ebb6e14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,7 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
***
*** autogen not found. Will not link against libopts.
*** ]])
- enable_local_libopts=yes
+ included_libopts=yes
fi
fi
@@ -523,7 +523,7 @@ fi
AM_CONDITIONAL(ENABLE_TROUSERS, test "$with_tpm" != "no")
-enable_local_libopts=no
+included_libopts=no
if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
LIBOPTS_CHECK([src/libopts])
if test "$NEED_LIBOPTS_DIR" = "true";then
@@ -540,15 +540,17 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
if test -z "$missing_baks"; then
AC_SUBST([AUTOGEN], [/bin/true])
fi
- enable_local_libopts=yes
+ included_libopts=yes
fi
else
# Need to ensure the relevant conditionals get set
gl_STDNORETURN_H
AM_CONDITIONAL([INSTALL_LIBOPTS],[false])
AM_CONDITIONAL([NEED_LIBOPTS], [false])
+ included_libopts=yes
fi
-AM_CONDITIONAL(NEED_LIBOPTS, test "$enable_local_libopts" = "yes")
+
+AM_CONDITIONAL(NEED_LIBOPTS, test "$included_libopts" = "yes")
AC_CHECK_TYPE(ssize_t,
[
@@ -896,7 +898,7 @@ AC_MSG_NOTICE([summary of build options:
Compiler: ${CC}
CFlags: ${CFLAGS}
Library types: Shared=${enable_shared}, Static=${enable_static}
- Local libopts: ${enable_local_libopts}
+ Local libopts: ${included_libopts}
Local libtasn1: ${included_libtasn1}
Use nettle-mini: ${mini_nettle}
])