summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2018-12-19 09:41:41 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2018-12-19 11:08:59 +0100
commit5b0ff19b08979f0c4d60cafcd23fcad8d61c3cc4 (patch)
treee165038ccb8c93d6d648d05f1c3ff762f172e390 /configure.ac
parent62f162f64c23a5e6b872ff8ee540d375b7e27168 (diff)
downloadgnutls-5b0ff19b08979f0c4d60cafcd23fcad8d61c3cc4.tar.gz
vasprintf: use from gnulib; don't bundle twice
Relates #653 Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 1 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 21ab6bbe9d..2530a805c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -293,7 +293,7 @@ AC_C_BIGENDIAN
dnl No fork on MinGW, disable some self-tests until we fix them.
dnl Check clock_gettime and pthread_mutex_lock in libc (avoid linking to other libs)
-AC_CHECK_FUNCS([fork setitimer inet_ntop inet_pton getrusage getpwuid_r nanosleep daemon getpid localtime vasprintf mmap explicit_bzero],,)
+AC_CHECK_FUNCS([fork setitimer inet_ntop inet_pton getrusage getpwuid_r nanosleep daemon getpid localtime mmap explicit_bzero],,)
dnl Manually check some functions by including headers first. On macOS, you
dnl normally only have the latest SDK available, containing all existing
dnl functions, but having them restricted according to target version in
@@ -311,28 +311,6 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <stdio.h>], [fmemopen(0, 0, 0);])],
[AC_MSG_RESULT(yes); ac_cv_func_fmemopen=yes
AC_DEFINE([HAVE_FMEMOPEN], 1, [Define to 1 if you have the `fmemopen' function.])],
[AC_MSG_RESULT(no); ac_cv_func_fmemopen=no])
-if test "$ac_cv_func_vasprintf" != "yes";then
- AC_MSG_CHECKING([for va_copy])
- AC_LINK_IFELSE([AC_LANG_PROGRAM([
- #include <stdarg.h>
- va_list a;],[
- va_list b;
- va_copy(b,a);
- va_end(b);])],
- [AC_DEFINE([HAVE_VA_COPY], 1, [Have va_copy()])
- AC_MSG_RESULT(va_copy)],
- [AC_LINK_IFELSE([AC_LANG_PROGRAM([
- #include <stdarg.h>
- va_list a;],[
- va_list b;
- __va_copy(b,a);
- va_end(b);])],
- [AC_DEFINE([HAVE___VA_COPY], 1, [Have __va_copy()])
- AC_MSG_RESULT(__va_copy)],
- [AC_MSG_RESULT(no)
- AC_MSG_ERROR([Your system lacks vasprintf() and va_copy()])])
- ])
-fi
AM_CONDITIONAL(HAVE_FORK, test "$ac_cv_func_fork" != "no")