summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2019-04-03 11:59:37 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2019-06-20 15:49:36 +0200
commit90142f2d70018d862cba02067159cad8c7db4239 (patch)
tree9ddc0fb58a01cd852dc024774e3255a7e76bef53 /configure.ac
parent4292c1ae6db9edd4b178c10bc5045534ea38e4a5 (diff)
downloadgnutls-90142f2d70018d862cba02067159cad8c7db4239.tar.gz
Use inih to parse configuration file
This introduces the inih copylib, and makes our configuration file parsing more flexible. Relates: #587 Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e0c5c25d5b..c2fe1794ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -950,6 +950,13 @@ dnl Some variables needed in makefiles
YEAR=`date +%Y`
AC_SUBST([YEAR], $YEAR)
+dnl configuration options for config file parsing (inih)
+AC_DEFINE([INI_MAX_LINE], 2048, [inih maximum line size])
+AC_DEFINE([INI_ALLOW_INLINE_COMMENTS], 1, [whether to allowin inline comments])
+AC_DEFINE([INI_STOP_ON_FIRST_ERROR], 1, [whether to stop on first error])
+AC_DEFINE_UNQUOTED([INI_INLINE_COMMENT_PREFIXES], [";#"], [The inline comment prefixes])
+AC_DEFINE_UNQUOTED([INI_START_COMMENT_PREFIXES], [";#"], [The comment prefixes])
+
AC_CONFIG_FILES([guile/pre-inst-guile], [chmod +x guile/pre-inst-guile])
AC_CONFIG_FILES([
Makefile