summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2019-09-23 21:05:48 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2019-09-23 21:05:51 +0200
commit9b43ce3ac6e087515c5e22e4f346db67e0a01de7 (patch)
tree5fec98ecdae503e19a2ba38375d23a0ed51a3b61 /configure.ac
parent54315879b33b45668860e406241aa04286044673 (diff)
downloadgnutls-9b43ce3ac6e087515c5e22e4f346db67e0a01de7.tar.gz
nettle: use nettle_get_secpp* consistently
We already depend on nettle 3.4.1 which provides that symbol, ensure that we use it consistently. Relates: #835 Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 71e655771d..72eee10d58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -562,7 +562,7 @@ AC_ARG_ENABLE(non-suiteb-curves,
if test "$enable_non_suiteb" = "yes";then
dnl nettle_secp_192r1 is not really a function
- AC_CHECK_LIB(hogweed, nettle_secp_192r1, enable_non_suiteb=yes, enable_non_suiteb=no, [$HOGWEED_LIBS $NETTLE_LIBS])
+ AC_CHECK_LIB(hogweed, nettle_get_secp_192r1, enable_non_suiteb=yes, enable_non_suiteb=no, [$HOGWEED_LIBS $NETTLE_LIBS])
if test "$enable_non_suiteb" = "yes";then
AC_DEFINE([ENABLE_NON_SUITEB_CURVES], 1, [Enable all curves])