summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Bar-Lev <alon.barlev@gmail.com>2019-03-23 00:38:17 +0200
committerAlon Bar-Lev <alon.barlev@gmail.com>2019-03-23 01:26:28 +0200
commitc0ccabfa594801eb441abbb4d4b24cae17cef691 (patch)
tree237989c456fadaa59f6f7a88463298c2814562f2 /configure.ac
parent8d2c1c345e1db472ef5d484d6ecc9ddbc794d791 (diff)
downloadgnutls-c0ccabfa594801eb441abbb4d4b24cae17cef691.tar.gz
configure.ac: remove --with-guile-site-dir
The hack of distcheck is not known and should not be the default as the GUILE_SITE_DIR macro is the default expected behavior. There is little value in specifying any other location of the site-dir as it is out of the guile configuration so best to remove. Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 1 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index e6305b4606..b142d8c397 100644
--- a/configure.ac
+++ b/configure.ac
@@ -825,10 +825,6 @@ AC_ARG_ENABLE(guile,
opt_guile_bindings=$enableval)
AC_MSG_RESULT($opt_guile_bindings)
-AC_ARG_WITH([guile-site-dir],
- [AS_HELP_STRING([--with-guile-site-dir],
- [use the given directory as the Guile site (use with care)])])
-
if test "$opt_guile_bindings" = "yes"; then
AC_MSG_RESULT([***
*** Detecting GNU Guile...
@@ -846,6 +842,7 @@ if test "$opt_guile_bindings" = "yes"; then
GUILE_PKG
GUILE_PROGS
+ GUILE_SITE_DIR
GUILE_FLAGS
save_CFLAGS="$CFLAGS"
@@ -864,24 +861,6 @@ if test "$opt_guile_bindings" = "yes"; then
if test "$opt_guile_bindings" = "yes"; then
AC_MSG_RESULT([yes])
- case "x$with_guile_site_dir" in
- xno)
- # Use the default $(GUILE_SITE).
- GUILE_SITE_DIR
- ;;
- x|xyes)
- # Automatically derive $(GUILE_SITE) from $(pkgdatadir). This
- # hack is used to allow `distcheck' to work (see
- # `DISTCHECK_CONFIGURE_FLAGS' in the top-level `Makefile.am').
- GUILE_SITE="\$(datadir)/guile/site/$guile_effective_version"
- AC_SUBST(GUILE_SITE)
- ;;
- *)
- # Use the user-specified directory as $(GUILE_SITE).
- GUILE_SITE="$with_guile_site_dir"
- AC_SUBST(GUILE_SITE)
- ;;
- esac
AC_MSG_CHECKING([whether gcc supports -fgnu89-inline])
_gcc_cflags_save="$CFLAGS"
CFLAGS="${CFLAGS} -fgnu89-inline"