summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2019-07-11 21:37:08 +0300
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2019-07-14 12:16:49 +0300
commitda8e1b83208f8736acf29a138be9ec4495418b1f (patch)
treee58597d2f3cff6db41f6509fb8dc674a02df1a1c /configure.ac
parent594572ab8055146e6d5941b580044bb0a6dbc87c (diff)
downloadgnutls-da8e1b83208f8736acf29a138be9ec4495418b1f.tar.gz
nettle/gost: support building with GOST-enabled Nettle
Nettle library starts to gain support for GOST algorithms. Support building GnuTLS with GOST-enabled nettle library. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e246fdcb73..9728f316ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -576,6 +576,23 @@ LIBS="$LIBS $NETTLE_LIBS"
AC_CHECK_FUNCS(xts_encrypt_message)
LIBS=$save_LIBS
+# Check for Gosthash94 with CryptoPro S-box support
+save_LIBS=$LIBS
+LIBS="$LIBS $NETTLE_LIBS"
+AC_CHECK_FUNCS(nettle_gosthash94cp_update)
+LIBS=$save_LIBS
+
+# Check for GOST28147
+save_LIBS=$LIBS
+LIBS="$LIBS $NETTLE_LIBS"
+AC_CHECK_FUNCS(nettle_gost28147_set_key)
+LIBS=$save_LIBS
+
+# Check for Streebog support
+save_LIBS=$LIBS
+LIBS="$LIBS $NETTLE_LIBS"
+AC_CHECK_FUNCS(nettle_streebog512_update)
+LIBS=$save_LIBS
AC_MSG_CHECKING([whether to build libdane])
AC_ARG_ENABLE(libdane,