summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-04-21 21:13:30 +0200
committerDaiki Ueno <dueno@redhat.com>2020-01-23 06:50:34 +0100
commitaf5e42aba4294ce09a263573febe840e804cf1ed (patch)
tree84d3076ef9183981cc25a8499b111800d82d54b5 /configure.ac
parent4023d63f0b2795c0c0447282c808671ae8503ac3 (diff)
downloadgnutls-af5e42aba4294ce09a263573febe840e804cf1ed.tar.gz
nettle: vendor in Curve448 and Ed448 implementation
Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8aa72f443b..2e73a904d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -650,6 +650,16 @@ LIBS="$LIBS $NETTLE_LIBS"
AC_CHECK_FUNCS(nettle_streebog512_update)
LIBS=$save_LIBS
+# Check for Curve448 and Ed448
+have_curve448=no
+save_LIBS=$LIBS
+LIBS="$LIBS $HOGWEED_LIBS $NETTLE_LIBS"
+AC_CHECK_FUNCS([nettle_curve448_mul nettle_ed448_shake256_sign],
+ [AC_DEFINE([HAVE_CURVE448], 1, [Enable Curve448])
+ have_curve448=yes])
+LIBS=$save_LIBS
+AM_CONDITIONAL(NEED_CURVE448, test "$have_curve448" != "yes")
+
AC_MSG_CHECKING([whether to build libdane])
AC_ARG_ENABLE(libdane,
AS_HELP_STRING([--disable-libdane],