summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2013-01-02 19:06:55 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-01-02 19:06:55 +0100
commit0fcbd34c953304dd06ebd49389af4b78575bd55b (patch)
tree5cc4b305df3d6c56960d5fb665f4c4389ebc07b0 /configure.ac
parentd88930e5077a558d4a073a0fe4462f6f35680acc (diff)
downloadgnutls-0fcbd34c953304dd06ebd49389af4b78575bd55b.tar.gz
tpm support is disabled by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a8393760d7..714a434aee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -273,8 +273,9 @@ fi
AM_CONDITIONAL(ENABLE_PKCS11, test "$with_p11_kit" != "no")
AC_ARG_WITH(tpm,
- AS_HELP_STRING([--without-tpm],
- [Build without TPM (trousers) support]))
+ AS_HELP_STRING([--with-tpm],
+ [Build with TPM (trousers) support. Note that trousers is under the Common Public License and incompatible with GPL programs.]),
+ [with_tpm=$withval], [with_tpm=no])
if test "$with_tpm" != "no"; then
LIBS="$oldlibs -ltspi"
AC_MSG_CHECKING([for tss library])