summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2013-03-02 10:57:04 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-03-02 10:57:04 +0100
commite018ea2c936721e904dc5cc0760b9d25020f526c (patch)
treec4e7bb1241f17d7692db79141ee10f1c627bceb4 /configure.ac
parent4f123f701cdbb2cfd8717c82b5bcb495d14048c5 (diff)
downloadgnutls-e018ea2c936721e904dc5cc0760b9d25020f526c.tar.gz
Select CPU optimizations based on target cpu rather than the host.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 03f937dfd8..4b32e39b1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,7 @@ AC_MSG_RESULT([***
])
dnl Checks for programs.
+AC_CANONICAL_TARGET
AC_PROG_CC
AM_PROG_AS
AC_PROG_CXX
@@ -87,17 +88,14 @@ hw_accel=none
if test "$use_accel" != "no"; then
-case $host_cpu in
+case $target_cpu in
i?86 | x86_64 | amd64)
-dnl GCC_FLAG_ADD([-maes -mpclmul],[X86])
-dnl if test "x$X86" = "xyes";then
AC_CHECK_HEADERS(cpuid.h)
- if test "$host_cpu" = "x86_64" || test "$host_cpu" = "amd64"; then
+ if test "$target_cpu" = "x86_64" || test "$target_cpu" = "amd64"; then
hw_accel="x86-64"
else
hw_accel="x86"
fi
-dnl fi
;;
*)
;;