summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2013-08-05 14:56:22 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-08-05 15:16:41 +0200
commit76cb4dd02a372adebf0db4e03a8c87029c464487 (patch)
tree9e6bca460eaaa56420bb2b3afd3e912da28d995b /configure.ac
parentdab19eac2c6b4c1ca66d9c4c22c0c1b7ac193310 (diff)
downloadgnutls-76cb4dd02a372adebf0db4e03a8c87029c464487.tar.gz
included programs no longer depend on GPL/LGPLv3 elements of gnulib to prevent their accidental inclusion in the library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 21b76fced9..e8660370b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,7 +206,7 @@ AC_PROG_LIBTOOL
dnl No fork on MinGW, disable some self-tests until we fix them.
dnl Check clock_gettime and pthread_mutex_lock in libc (avoid linking to other libs)
-AC_CHECK_FUNCS([fork getrusage getpwuid_r nanosleep daemon getpid clock_gettime pthread_mutex_lock iconv localtime],,)
+AC_CHECK_FUNCS([fork getrusage getpwuid_r nanosleep daemon getpid clock_gettime pthread_mutex_lock iconv localtime vasprintf],,)
AM_CONDITIONAL(HAVE_FORK, test "$ac_cv_func_fork" != "no")
if test "$ac_cv_func_pthread_mutex_lock" != "yes";then
@@ -568,9 +568,10 @@ AC_ARG_ENABLE(crywrap,
if test "x$enable_crywrap" != "xno" ; then
PKG_CHECK_MODULES(LIBIDN, libidn >= 0.0.0, [libidn=yes], [libidn=no])
+ AC_CHECK_FUNCS([argp_usage],[ac_argp=yes],[ac_argp=no])
fi
- if test "x$libidn" != "xno" && test "$ac_cv_func_daemon" != "no";then
+ if test "x$libidn" != "xno" && test "$ac_cv_func_daemon" != "no" && test "$ac_argp" != "no";then
crywrap=yes
fi