summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-15 15:45:46 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-27 11:41:43 +0100
commit885d3e2fa7abd153b3847358eceda8f66fd4ca52 (patch)
tree76561094855b4143c3956e1148cdb5d48f29e6f8 /configure.ac
parentb3bb0df8c5a4d24d57c6c49af9d21cc2a4e5d97f (diff)
downloadgnutls-885d3e2fa7abd153b3847358eceda8f66fd4ca52.tar.gz
Ported libgcrypt's AES-based DRBG.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 18b03117d7..6040823dd9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,6 +134,12 @@ if [ test "$enable_fips" = "yes" ];then
AC_LIB_HAVE_LINKFLAGS(dl,, [#include <dlfcn.h>], [dladdr (0, 0);])
if test "x$HAVE_LIBDL" = "xyes";then
enable_self_checks=yes
+
+ dnl clock_gettime precision is needed on the FIPS140 DRBG.
+ if test "$ac_cv_func_clock_gettime" != "yes";then
+ AC_LIB_HAVE_LINKFLAGS(rt,, [#include <time.h>], [clock_gettime (0, 0);])
+ fi
+
AC_DEFINE([ENABLE_FIPS140], 1, [Enable FIPS140-2 mode])
AC_SUBST([FIPS140_LIBS], $LIBDL)