summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2001-07-30 09:56:28 +0000
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2001-07-30 09:56:28 +0000
commitf7e2ee106479eb3166a3e6ac5c40ec7b80a13fdb (patch)
tree235cfea2c900206f0405960b5ba300f01843617c /configure.in
parent7951e12f31002b63d78f181b13044fe7fbee9547 (diff)
downloadgnutls-f7e2ee106479eb3166a3e6ac5c40ec7b80a13fdb.tar.gz
added profiler option
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 898835beb8..666983ca81 100644
--- a/configure.in
+++ b/configure.in
@@ -67,7 +67,7 @@ AC_MSG_RESULT($opt_maintainer_mode)
opt_profiler_mode=no
AC_MSG_CHECKING([whether in profile mode])
AC_ARG_ENABLE(profile-mode,
-[ --enable-profile-mode enable profiler (gcov/gprof)],
+[ --enable-profile-mode enable profiler],
opt_profiler_mode=$enableval)
AC_MSG_RESULT($opt_profiler_mode)
@@ -104,10 +104,15 @@ if test $ac_cv_c_compiler_gnu != no; then
CFLAGS=""
if test $opt_profiler_mode = yes; then
- CFLAGS="${CFLAGS} -O0 -fprofile-arcs -ftest-coverage -pg"
+ CFLAGS="${CFLAGS} -O0 -fprofile-arcs -finstrument-functions -ftest-coverage"
+ AC_CHECK_LIB(fnccheck, main,
+ LIBS="$LIBS -lfnccheck",
+ AC_MSG_ERROR("You must install libfnccheck in order to enable profiling. http://www710.univ-lyon1.fr/~yperret/fnccheck/profiler.html")
+ )
fi
if test $opt_maintainer_mode = yes; then
+
CFLAGS="${CFLAGS} -O0 -ggdb3 -Wall -Wpointer-arith"
else
CFLAGS="${CFLAGS} -O2"