summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2003-09-12 13:13:53 +0000
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2003-09-12 13:13:53 +0000
commit98e498ef65f25a2a264f50d1b6c7aa49e8ae9509 (patch)
tree25bfa29835f68a1e228c649d7513560b3e982371 /configure.in
parent949f8e50cd9be374b7b312df0ab2e23019522d8c (diff)
downloadgnutls-98e498ef65f25a2a264f50d1b6c7aa49e8ae9509.tar.gz
Some additions to export only the documented API, and some support for versioning.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0e09644cc9..57a7673820 100644
--- a/configure.in
+++ b/configure.in
@@ -148,6 +148,18 @@ if test $ac_cv_c_compiler_gnu != no; then
fi
fi
+AC_MSG_CHECKING([whether we have GNU ld or compatible])
+
+GLD=`ld --help < /dev/null 2>/dev/null | grep version-script`
+if test "$GLD"; then
+have_ld_version_script=yes
+ AC_MSG_RESULT(yes)
+else
+have_ld_version_script=no
+ AC_MSG_RESULT(no)
+fi
+
+AM_CONDITIONAL(HAVE_LD_VERSION_SCRIPT, test "$have_ld_version_script" = "yes")
AC_MSG_RESULT([***
*** Detecting C library capabilities...