summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2003-09-13 06:13:25 +0000
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2003-09-13 06:13:25 +0000
commitb3c60f19df7da1c638f57eab18165b26d486563f (patch)
treeed3d8578d7ef3e85ba38a79e7f85a7294c766747 /configure.in
parent9c970ce61bc80dd4e27b8e03c1077c12ea496ea0 (diff)
downloadgnutls-b3c60f19df7da1c638f57eab18165b26d486563f.tar.gz
*** empty log message ***
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 19 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 57a7673820..d6380848cc 100644
--- a/configure.in
+++ b/configure.in
@@ -148,18 +148,6 @@ if test $ac_cv_c_compiler_gnu != no; then
fi
fi
-AC_MSG_CHECKING([whether we have GNU ld or compatible])
-
-GLD=`ld --help < /dev/null 2>/dev/null | grep version-script`
-if test "$GLD"; then
-have_ld_version_script=yes
- AC_MSG_RESULT(yes)
-else
-have_ld_version_script=no
- AC_MSG_RESULT(no)
-fi
-
-AM_CONDITIONAL(HAVE_LD_VERSION_SCRIPT, test "$have_ld_version_script" = "yes")
AC_MSG_RESULT([***
*** Detecting C library capabilities...
@@ -399,6 +387,25 @@ AC_MSG_RESULT([***
])
AM_PROG_LIBTOOL
+dnl This is after AM_PROG_LIBTOOL so that the LD variable
+dnl has been set.
+
+AC_MSG_CHECKING([whether we have GNU ld or compatible])
+
+GLD=`$LD --help < /dev/null 2>/dev/null | grep version-script`
+if test "$GLD"; then
+have_ld_version_script=yes
+ AC_MSG_RESULT(yes)
+else
+have_ld_version_script=no
+ AC_MSG_RESULT(no)
+AC_MSG_WARN(***
+*** You may want to rerun configure using --with-gnu-ld to enable versioned symbols.
+)
+fi
+
+AM_CONDITIONAL(HAVE_LD_VERSION_SCRIPT, test "$have_ld_version_script" = "yes")
+
LIBGNUTLS_LIBS="$LIBS -L${libdir} -lgnutls $LIBASN1_LINK $LIBGCRYPT_LIBS"
LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS -I${includedir}"