summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2003-11-11 21:00:29 +0000
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2003-11-11 21:00:29 +0000
commit43ca2890ff0d043a4343cb277c534d9711a642b5 (patch)
tree8324655ed8fed4c93b125305adcda21920bc6b06 /configure.in
parentcc01e539a47a78bb43e341a922cf2583f18aa692 (diff)
downloadgnutls-43ca2890ff0d043a4343cb277c534d9711a642b5.tar.gz
Patch by Werner Koch:
* configure.in: Check for gcry_create_nonce. * lib/gnutls_random.c (_gnutls_get_random): Ditto. * src/crypt.c (_srp_crypt): Use gcry_create_nonce if available. Also removed some unneeded code in random.c.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 352a00fc36..fa14cc0351 100644
--- a/configure.in
+++ b/configure.in
@@ -246,6 +246,15 @@ AM_PATH_LIBGCRYPT($GNUTLS_GCRYPT_VERSION,,
dnl Can't disable - gnutls depends on gcrypt
AC_DEFINE(USE_GCRYPT, 1, [use gcrypt])
+# Since libgcrypt 1.1.90 we have a new function to create nonces etc.
+# it is useful to use this one instead of the the standard random
+# functions. As a temporary solution we check for that function and
+# don't require an unrelease libgcrypt. This should be changed after
+# libgcrypt 1.2 has been released.
+save_LIBS="$LIBS"
+LIBS="$LIBS $LIBGCRYPT_LIBS"
+AC_CHECK_FUNCS(gcry_create_nonce)
+LIBS="$save_LIBS"
AC_MSG_CHECKING([whether to disable SRP authentication support])