summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2003-11-13 06:41:09 +0000
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2003-11-13 06:41:09 +0000
commit94a3785fb6a87d74fbc6efa65efd777e528c03ba (patch)
tree28cefcbef8fb58e92c1a3372b9b7b5fd1fca30ff /configure.in
parent4c0253a2a634f8ec4e51d1e79f8916da7113a392 (diff)
downloadgnutls-94a3785fb6a87d74fbc6efa65efd777e528c03ba.tar.gz
The openssl compatibility layer was moved to gnutls-openssl to allow the extension of it without bloating the libgnutls-extra.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fa14cc0351..a95260510d 100644
--- a/configure.in
+++ b/configure.in
@@ -308,17 +308,19 @@ else
AC_MSG_RESULT(yes)
fi
+ac_enable_openssl=yes
AC_MSG_CHECKING([whether to disable OpenSSL compatibility layer])
AC_ARG_ENABLE( openssl-compatibility, [ --disable-openssl-compatibility Disable the OpenSSL compatibility support],
ac_enable_openssl=no
)
if test x$ac_enable_openssl != xno; then
AC_MSG_RESULT(no)
- AC_DEFINE(ENABLE_OPENSSL, 1, [enable openssl compatibility layer])
else
AC_MSG_RESULT(yes)
fi
+AM_CONDITIONAL(ENABLE_OPENSSL, test "$ac_enable_openssl" = "yes")
+
AC_ARG_WITH(included-libtasn1,
[ --with-included-libtasn1 Use the included libtasn1],